Contact   Imprint   Advertising   Guidelines

little help please

A forum dedicated to Hydrofoil riders


spacemonkey
Medium Poster
Posts: 147
Joined: Mon Aug 18, 2003 9:10 pm

little help please

Postby spacemonkey » Thu Aug 14, 2014 10:34 am

My setup is a Temavento board with Taaroa Sword.

I always ride it with straps, but when i put my foot in the back strap it feels like i'm not in the sweet spot, feels like i'm going over the cliff.. When i put my backfoot just in front of the backstrap it feels really great.

Does this mean that i'm doing something wrong or is the position of my foil wrong?

By the way: front straps in neutral position (middle hole , there are 3), back strap most toward the nose.

thanks for any help

ozchrisb
Frequent Poster
Posts: 275
Joined: Sat Dec 29, 2012 2:59 am
Kiting since: 1999
Brand Affiliation: None

Re: little help please

Postby ozchrisb » Thu Aug 14, 2014 3:25 pm

I have that setup and have the foot straps all the way forward for the front and back. Try moving your front ones forward. It would have bee nice to go forward even further I think, but thats where they ended up.

spacemonkey
Medium Poster
Posts: 147
Joined: Mon Aug 18, 2003 9:10 pm

Re: little help please

Postby spacemonkey » Fri Aug 15, 2014 10:24 am

Could you measure the distance of the foil inserts (or edge of the base plate) to the back of you board.

This to compare with mine and to check if they are equal.

Maybe the foil should be more toward the back?




ozchrisb wrote:I have that setup and have the foot straps all the way forward for the front and back. Try moving your front ones forward. It would have bee nice to go forward even further I think, but thats where they ended up.


Return to “Hydrofoil”

Who is online

Users browsing this forum: mar tin and 6 guests

cron